StrokesPlus.net
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Sherif Aliti  
#1 Posted : Monday, February 22, 2021 6:30:14 AM(UTC)
Sherif Aliti

Rank: Member

Reputation:

Groups: Approved
Joined: 2/16/2021(UTC)
Posts: 10
Albania
Location: Fier

Thanks: 6 times
[img=http://postimg.cc/DW5y0X1x]Error[/img]

What can be wrong here?

Plus when i click on Hotkeys i am getting this error message and Software hang

SW Hang


Should i open new threads for bugs and Questions or all in 1 thread ?

Thanks in advance


Rob  
#2 Posted : Monday, February 22, 2021 7:29:41 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 865
United States
Location: Tampa, FL

Thanks: 20 times
Was thanked: 222 time(s) in 193 post(s)
For the first one, what is your script for RunProgram?

For the second, I might need you to email me your StrokesPlus.net.bin file so I can debug and see where it's crashing.
The file is usually in C:\USers\{USERNAME}\AppData\Roaming\StrokesPlus.net

You can post in the same thread, I don't enforce a bunch of forum rules.
thanks 1 user thanked Rob for this useful post.
Sherif Aliti on 2/22/2021(UTC)
Rob  
#3 Posted : Monday, February 22, 2021 7:36:45 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 865
United States
Location: Tampa, FL

Thanks: 20 times
Was thanked: 222 time(s) in 193 post(s)
Oh, rob@strokesplus.net is my email
Sherif Aliti  
#4 Posted : Monday, February 22, 2021 9:51:21 AM(UTC)
Sherif Aliti

Rank: Member

Reputation:

Groups: Approved
Joined: 2/16/2021(UTC)
Posts: 10
Albania
Location: Fier

Thanks: 6 times
Originally Posted by: Rob Go to Quoted Post
For the first one, what is your script for RunProgram?

For the second, I might need you to email me your StrokesPlus.net.bin file so I can debug and see where it's crashing.
The file is usually in C:\USers\{USERNAME}\AppData\Roaming\StrokesPlus.net

You can post in the same thread, I don't enforce a bunch of forum rules.


About the first one, there is no script, I just try to execute specific software via mouse gestures
about the second one I sent you a bin file in email

Sherif Aliti  
#5 Posted : Tuesday, February 23, 2021 3:00:52 AM(UTC)
Sherif Aliti

Rank: Member

Reputation:

Groups: Approved
Joined: 2/16/2021(UTC)
Posts: 10
Albania
Location: Fier

Thanks: 6 times
Originally Posted by: Sherif Aliti Go to Quoted Post
Originally Posted by: Rob Go to Quoted Post
For the first one, what is your script for RunProgram?

For the second, I might need you to email me your StrokesPlus.net.bin file so I can debug and see where it's crashing.
The file is usually in C:\USers\{USERNAME}\AppData\Roaming\StrokesPlus.net

You can post in the same thread, I don't enforce a bunch of forum rules.


About the first one, there is no script, I just try to execute specific software via mouse gestures
about the second one I sent you a bin file in email



I made a video for a better explanation
Even if the software will run it will be blocked (non-responding or hidden on visible ) - That software run with administrative privileges but when run via strokes it will run WO them
anyway I don't think is due to administrative privileges because it happens with other software too

The second that happens is if we execute software and after the close, if we want to execute again stroke not work anymore

Video on Youtube




Rob  
#6 Posted : Tuesday, February 23, 2021 7:17:23 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 865
United States
Location: Tampa, FL

Thanks: 20 times
Was thanked: 222 time(s) in 193 post(s)
Try this for programs that need to run as admin:

Use Run Program instead with these parameters:

Code:
fileName:        EXE like normal
arguments:       (none, leave empty)
verb:            runas
windowStyle:     normal
useShellExecute: False
noWindow:        False
waitForExit:     False

The runas verb tells Windows to run the task with admin privileges


As far as not being able to interact, that is odd. What do you have for these checkboxes under Options > Advanced?

- Draw Surface Always on Top
- Send Draw Surface to Bottom
thanks 1 user thanked Rob for this useful post.
Sherif Aliti on 2/23/2021(UTC)
Sherif Aliti  
#7 Posted : Tuesday, February 23, 2021 8:42:39 AM(UTC)
Sherif Aliti

Rank: Member

Reputation:

Groups: Approved
Joined: 2/16/2021(UTC)
Posts: 10
Albania
Location: Fier

Thanks: 6 times
Originally Posted by: Rob Go to Quoted Post
Try this for programs that need to run as admin:

Use Run Program instead with these parameters:

Code:
fileName:        EXE like normal
arguments:       (none, leave empty)
verb:            runas
windowStyle:     normal
useShellExecute: False
noWindow:        False
waitForExit:     False

The runas verb tells Windows to run the task with admin privileges


As far as not being able to interact, that is odd. What do you have for these checkboxes under Options > Advanced?

- Draw Surface Always on Top
- Send Draw Surface to Bottom


Still same, not run.. About advanced checkboxes are untouched.

Error

Added verb run as

Advanced checkbox

Advanced checkbox II







Rob  
#8 Posted : Tuesday, February 23, 2021 9:25:50 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 865
United States
Location: Tampa, FL

Thanks: 20 times
Was thanked: 222 time(s) in 193 post(s)
Are you running S+ via the installer, or are you using the portable version of S+?

The installer runs in an elevated state, but the portable version does not.
thanks 1 user thanked Rob for this useful post.
Sherif Aliti on 2/24/2021(UTC)
Rob  
#9 Posted : Tuesday, February 23, 2021 9:35:14 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 865
United States
Location: Tampa, FL

Thanks: 20 times
Was thanked: 222 time(s) in 193 post(s)
Also, try changing useShellExecute to True, and/or this script:
Code:
sp.RunProgram("C:\\Program Files (x86)\\3uTools\\3uTools.exe", "", "runas", "normal", true, false, false); 
thanks 1 user thanked Rob for this useful post.
Sherif Aliti on 2/24/2021(UTC)
Sherif Aliti  
#10 Posted : Wednesday, February 24, 2021 4:47:20 AM(UTC)
Sherif Aliti

Rank: Member

Reputation:

Groups: Approved
Joined: 2/16/2021(UTC)
Posts: 10
Albania
Location: Fier

Thanks: 6 times
Originally Posted by: Rob Go to Quoted Post
Also, try changing useShellExecute to True, and/or this script:
Code:
sp.RunProgram("C:\\Program Files (x86)\\3uTools\\3uTools.exe", "", "runas", "normal", true, false, false); 


Both methods work gr8, thanks

Script work as standalone and with use shell execute correct problem.

Regards

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.