StrokesPlus.net
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Swagboy69  
#1 Posted : Friday, March 15, 2024 12:19:54 PM(UTC)
Swagboy69

Rank: Member

Reputation:

Groups: Approved
Joined: 8/31/2021(UTC)
Posts: 13
United States

Thanks: 1 times
Hi @Rob and everyone,

This problem popped up alongside my previous "JSON corruption" error that I posted below. Here's a screenshot.

[img=https://1drv.ms/i/s!AsuOdiR9EFUnjZ9hiHj3w_-9uuzx2Q]missing glyphs[/img]

missing glyphs

As you can see, those "diamonds with question marks" indicate that specific font character/glyph is missing. It's called an "en dash" ( – ), basically a longer hyphen.

Also missing is the "pipe" character ( | ), which is the shifted+backslash key above "ENTER".

These font characters/glyphs DOES render correctly everywhere else on my PC, both natively in Windows and in other apps.

As I described in my other post, all these problems happened after a virus-removal and subsequent restart and crash. The characters are even not being rendered after I'd imported a backup profile, so something within SP is persisting.

It's not a huge deal, this is more about my curiousity so that if I understand what happened, perhaps we can avoid it in the future. Thanks!

Edited by user Friday, March 15, 2024 12:20:56 PM(UTC)  | Reason: Not specified

Rob  
#2 Posted : Friday, March 15, 2024 1:14:24 PM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 1,359
United States
Location: Tampa, FL

Thanks: 28 times
Was thanked: 419 time(s) in 356 post(s)
It sounds to me like your settings file's encoding is ASCII or something else, instead of UTF-8.

Open the StrokesPlus.net.json file in Notepad and go to File > Save As... - look in the lower right and see what the Encoding dropdown shows.
Swagboy69  
#3 Posted : Friday, March 15, 2024 1:20:33 PM(UTC)
Swagboy69

Rank: Member

Reputation:

Groups: Approved
Joined: 8/31/2021(UTC)
Posts: 13
United States

Thanks: 1 times
Hi Rob, thanks for the quick reply.

I opened the "StrokesPlus.net.json" file up in Notepad++, and it says "UTF-8" in both the "encoding" dropdown and the bottom right-corner.
Rob  
#4 Posted : Friday, March 15, 2024 5:18:55 PM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 1,359
United States
Location: Tampa, FL

Thanks: 28 times
Was thanked: 419 time(s) in 356 post(s)
If you search in the file for "Jump back" do you see the correct glyph in the JSON file text?
Swagboy69  
#5 Posted : Friday, March 15, 2024 5:54:34 PM(UTC)
Swagboy69

Rank: Member

Reputation:

Groups: Approved
Joined: 8/31/2021(UTC)
Posts: 13
United States

Thanks: 1 times
Originally Posted by: Rob Go to Quoted Post
If you search in the file for "Jump back" do you see the correct glyph in the JSON file text?



Wow, actually no – still seeing the "diamond-?" glyph.

So I went ahead and searched for the "diamond-?" glyph, which gave 223 hits!

Does this mean that it's not a rendering problem but rather a mapping problem? If I replace all the diamonds with my desired glyph, would that work? Interesting... I'll make a backup and test it!

Update: I think that worked! I wonder why it happened in the first place, but now I know we can batch-replace stuff in the JSON :) Thanks Rob

Edited by user Friday, March 15, 2024 6:05:45 PM(UTC)  | Reason: Not specified

Rob  
#6 Posted : Friday, March 15, 2024 7:13:43 PM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 1,359
United States
Location: Tampa, FL

Thanks: 28 times
Was thanked: 419 time(s) in 356 post(s)
I'm not sure, but you mentioned reinstalling and using a backed up config.

So I guess it would be something to look at, what is touching that file which could've lost the encoding.

Not to say S+ couldn't be the cause under some odd scenario, just good to keep an open mind to see if some other process isn't preserving the encoding.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.