logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
esv  
#1 Posted : Wednesday, October 10, 2018 7:25:07 AM(UTC)
esv

Rank: Newbie

Reputation:

Groups: Approved
Joined: 10/10/2018(UTC)
Posts: 3
Russian Federation

I've mapped SecondaryStroke (which is a side button on my mouse)+LeftMouseButton with capture modifiers: either to play/pause
Code:
// Play or pause current playing media
sp.SendVKey(vk.MEDIA_PLAY_PAUSE);


Every now and then I notice that my LeftMouseButton just stops working either
1) altogether: can't click anywhere, only keyboard is working, though when this happened last time I've noticed that other StrokesPlus commands are working (e.g. Primary/SecondaryStrok+MoveMouseLeft/Right continue to function)
2) partially: can't click on the taskbar, Strokes are not working, but I can click normally within applications

This seems to pass after a few seconds and regular mouse functions come back to life, though sometimes (seems to be more likely after #2) StrokesPlus stops working (even after reload) and I have to restart it
UPD: though sometimes a few seconds is not enough and I have to do Ctrl+Alt+Del to fix it (simply invoking this key combo seems to be enough)

Not sure where I could get more info/logs to help troubleshoot it, please let me know if there is any additional info that's needed and where to get it

StrokesPlus version 0.2.5.7
Windows x64 10.0.17134.0
FYI I've also symlinked AppData\Roaming\StrokesPlus folder to Dropbox

Edited by user Wednesday, October 10, 2018 10:01:54 AM(UTC)  | Reason: Not specified

Rob  
#2 Posted : Wednesday, October 10, 2018 8:44:40 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Administrators
Joined: 1/11/2018(UTC)
Posts: 2
United States

Was thanked: 5 time(s) in 1 post(s)
Sounds like the hook function is getting stuck in processing or crashing somewhere. Windows will give a low-level hooked application a little bit to respond, but then it will stop sending messages to the hooked application after 4-10 seconds; often times until it's restarted, if it wasn't a program crash.

Naturally, these are difficult scenarios to troubleshoot. However, I do have a trace build configuration to log events in these situations, which you can download below.

Trace Installer

Trace Portable


It will create .log files (one per run) in the \AppData\Roaming\StrokesPlus.net\Log folder or maybe in the same folder if portable (haven't tested that yet).

You can pick any events to capture trace data, but these would probably be the only ones needed for your situation:

CoreCaptureEvents
MouseHookGeneralEvents
HookTimerEvents
HookStateGeneralEvents

Obviously, you wouldn't want to run the trace version of S+.net any longer than necessary, due to the increased overhead and reduction in performance. So it would be best to see if you can narrow down a way to reproduce the issue, but this sounds like a race condition which means it will be challenging to consistently reproduce. However, the moment after this happens again (while running the trace version), kill S+.net so the log entries at the end of the file will be the entries of interest. The trace logs will fill up very fast with a LOT of entries...

Note that this version is 0.2.5.8, an in progress version I haven't touched in a long time, below are the change entries I have noted so far.
Note that last item, as it's possible that unreleased fix could address your issue...or not, hard to say based on the wording and my poor memory.

  • Hopefully fixed new gesture form layout, form's font was set smaller than controls, so scaling
    was not behaving as expected. However, some other forms have a smaller size and haven't been
    reported, but could be those forms are not visibly impacted
  • Added "minimized" as an accepted value for the "style" parameter of sp.RunProgram
  • Ampersands (&) will now be displayed in the hint and display text popup
  • Fixed regression issue with rocker gestures, where left down and multiple right clicks was not
    functioning as intended. Issue started with 0.2.4.6 as a result of correcting a random bug, so
    the bug might show itself again (S+ getting stuck in rocker/stroke button down state)
esv  
#3 Posted : Wednesday, October 10, 2018 11:04:48 AM(UTC)
esv

Rank: Newbie

Reputation:

Groups: Approved
Joined: 10/10/2018(UTC)
Posts: 3
Russian Federation

Actually, it turns out to be an easily reproduceable issue, I can consistently bug it out within the first few seconds, so the logs aren't big

Please download this zipped file that contains the following files:
- StrokesPlus.net.bin - my current StrokesPlus settings that I copied&pasted to the new StrokesPlus.net config folder (I've used the portable version, but it still read configs from AppData\Roaming\StrokesPlus.net (and put logs there as well, sot it's not really portable BigGrin )

The following two traces are with the four trace options you mentioned
- trace_2018-10-10_06-44-57-PM-killed.log - killed from Task Manager
- trace_2018-10-10_06-38-40-PM-manual exit.log - waited till mouse became responsive and quit the regular way from tray icon

The following two traces are with all the trace options enabled
- trace_2018-10-10_06-48-21-PM-ALL-killed.log - killed from Task Manager
- trace_2018-10-10_06-49-59-PM-ALL-CtrlAltDel-manual-exit.log - used Ctrl+Alt+Del to regain mouse responsiveness and quit the regular way from tray icon


Hope this is enough details for you to find the bug
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.