StrokesPlus.net
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
jerrypolten  
#1 Posted : Saturday, November 21, 2020 6:22:59 PM(UTC)
jerrypolten

Rank: Newbie

Reputation:

Groups: Approved
Joined: 11/21/2020(UTC)
Posts: 4

Hello,

I have just discovered this program and I am very excited. Unfortunately I still can't use it for a number of problems.

1. The only stroke button that works is the left button. If I set the middle or right button, the mouse function prevails over the program function.
2. Point 1 is penalizing because unfortunately the left button is used for many things (e.g. drag and drop).
3. Every time I open the settings to change something, the toggle is activated (which I don't want). Each time I deactivate the toggle but as soon as I open the settings the toggle returns.
4. I can't exclude the program from some contexts, Edge for example (I used msedge.exe in the exclusions section but it doesn't work).

Can you help me fix it so I can use this great program? Thanks in advance!
Rob  
#2 Posted : Saturday, November 21, 2020 11:12:59 PM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 926
United States
Location: Tampa, FL

Thanks: 21 times
Was thanked: 265 time(s) in 231 post(s)
1. There's no known reason this should be happening. Do you have any other utilities running which might be hooking the mouse?
3. What exactly do you mean by "toggle"?
4. I added msedge.exe as the Module Name (EXE) (other fields left blank) and checked Active - it seems to work fine for me. Do you have any other details?
jerrypolten  
#3 Posted : Sunday, November 22, 2020 8:48:59 AM(UTC)
jerrypolten

Rank: Newbie

Reputation:

Groups: Approved
Joined: 11/21/2020(UTC)
Posts: 4

1. No utilities. I just right click (if the stroke is set to right) and instead of the SP gesture I see the menu (the one that usually appear when you right click something).
3. I mean the floaters. For example, I've just turned on the PC and the floaters are there (I disabled them before turning off the PC).
4. I don't know why it doesn't work for me.
Rob  
#4 Posted : Sunday, November 22, 2020 11:42:45 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 926
United States
Location: Tampa, FL

Thanks: 21 times
Was thanked: 265 time(s) in 231 post(s)
You may want to try using the trace build and reviewing the log files and/or posting snippets here, as no one has ever reported the right button not working.

Trace build info

Are you using a physical mouse?

I'm not about the floaters, I will have to look into that.
How are you toggling them off before shutting down? (tray menu, floater menu, script?)
Rob Otter  
#5 Posted : Monday, November 23, 2020 12:57:19 PM(UTC)
Rob Otter

Rank: Advanced Member

Reputation:

Groups: Approved
Joined: 10/26/2020(UTC)
Posts: 50
Germany
Location: Darmstadt

Thanks: 15 times
Was thanked: 2 time(s) in 2 post(s)
Originally Posted by: jerrypolten Go to Quoted Post
1. No utilities. I just right click (if the stroke is set to right) and instead of the SP gesture I see the menu (the one that usually appear when you right click something).

Just to be sure: If you´re talking about "clicking", do you mean pressing the mouse button and releasing it? If so, try holding the (right) mouse button and move the mouse.
Even if not moving, the context menu should not appear before releasing the button.
I don´t mean to make you look stupid - but sometimes it´s just the simple things...
jerrypolten  
#6 Posted : Tuesday, December 8, 2020 11:51:26 AM(UTC)
jerrypolten

Rank: Newbie

Reputation:

Groups: Approved
Joined: 11/21/2020(UTC)
Posts: 4

Hello, I tried a couple of gestures, but only one works.

One is to search a word in Google (when highlighted in the browser page) and it works:
sp.SendVKey(vk.APPS);
sp.Sleep
sp.SendVKey(vk.VK_R);

The other is to open a url that has not a link, just a www. (when highlighted in the browser page) and it doesn't work:
sp.SendVKey(vk.APPS);
sp.SendVKey(vk.VK_S);
sp.SendVKey(vk.RETURN);

I don't know why the first one works and the second one does not. They have the same logic. Thanks.

Rob  
#7 Posted : Tuesday, December 8, 2020 2:06:26 PM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 926
United States
Location: Tampa, FL

Thanks: 21 times
Was thanked: 265 time(s) in 231 post(s)
Originally Posted by: jerrypolten Go to Quoted Post
Hello, I tried a couple of gestures, but only one works.

One is to search a word in Google (when highlighted in the browser page) and it works:
sp.SendVKey(vk.APPS);
sp.Sleep
sp.SendVKey(vk.VK_R);

The other is to open a url that has not a link, just a www. (when highlighted in the browser page) and it doesn't work:
sp.SendVKey(vk.APPS);
sp.SendVKey(vk.VK_S);
sp.SendVKey(vk.RETURN);

I don't know why the first one works and the second one does not. They have the same logic. Thanks.


What browser are you using? I don't have R or S as popup menu key accelerators, so I can't try to troubleshoot the issue.
I looked in Chrome, Firefox, and Edge, but pressing the Apps key then R or S don't do anything.
Do you have any extensions or custom keys defined?
jerrypolten  
#8 Posted : Tuesday, December 8, 2020 3:34:06 PM(UTC)
jerrypolten

Rank: Newbie

Reputation:

Groups: Approved
Joined: 11/21/2020(UTC)
Posts: 4

Originally Posted by: Rob Go to Quoted Post
Originally Posted by: jerrypolten Go to Quoted Post
Hello, I tried a couple of gestures, but only one works.

One is to search a word in Google (when highlighted in the browser page) and it works:
sp.SendVKey(vk.APPS);
sp.Sleep
sp.SendVKey(vk.VK_R);

The other is to open a url that has not a link, just a www. (when highlighted in the browser page) and it doesn't work:
sp.SendVKey(vk.APPS);
sp.SendVKey(vk.VK_S);
sp.SendVKey(vk.RETURN);

I don't know why the first one works and the second one does not. They have the same logic. Thanks.


What browser are you using? I don't have R or S as popup menu key accelerators, so I can't try to troubleshoot the issue.
I looked in Chrome, Firefox, and Edge, but pressing the Apps key then R or S don't do anything.
Do you have any extensions or custom keys defined?


I think it's language-related. So in Firefox, if you click on the apps (or right click on the mouse), you have several possibilities. R is to search on Google, S is to open the url in a new tab.
Rob  
#9 Posted : Tuesday, December 8, 2020 3:57:35 PM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 926
United States
Location: Tampa, FL

Thanks: 21 times
Was thanked: 265 time(s) in 231 post(s)
Oh okay, it looks like it is G for English - but this works for me:
Code:
sp.SendVKey(vk.APPS);
sp.Sleep(10);
sp.SendVKey(vk.VK_G);
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.