StrokesPlus.net
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Pidgeon  
#1 Posted : Friday, September 25, 2020 2:42:27 PM(UTC)
Pidgeon

Rank: Newbie

Reputation:

Groups: Approved
Joined: 9/25/2020(UTC)
Posts: 6
Italy

Thanks: 1 times
Hi everyone, this is my first post in this board.

First of all I want to express my congratulations to the author of StrokesPlus.Net, really an excellent software!

I would like to start by reporting a very strange bug which began to occur recently.

When associating a piece of code similar to this one to a gesture:

Code:
sp.SendModifiedVKeys([vk.LCONTROL,vk.LMENU], [vk.SPACE]);


once the action is triggered, the involved key modifiers (Alt and Ctrl in this case) are kept active, even once the action ends, as if they were stuck.

Further hotkeys don't work. The only way to go back to "normal" state, is to manually press again the Ctrl and Alt modifiers.

My problem seems to be related to this one:

https://www.strokesplus....iendly.asp?TOPIC_ID=1403

The strange thing is that I never had this problem on my PC. Then, for somewhat reason, it started occurring more or less one week ago.

It is driving me crazy, hopefully there'll be a solution for this one!

In case it is necessary for me to conduct specific tests, there wouldn't be any problem my side.

Edited by user Friday, September 25, 2020 3:53:29 PM(UTC)  | Reason: Not specified

Rob  
#2 Posted : Saturday, September 26, 2020 7:23:40 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 718
United States
Location: Tampa, FL

Thanks: 14 times
Was thanked: 163 time(s) in 141 post(s)
What is the intent of this action? Ctrl+Alt+Space doesn't do anything for me.

Is this used in a specific app?

What is supposed to happen when you press this?
thanks 1 user thanked Rob for this useful post.
Pidgeon on 9/26/2020(UTC)
Pidgeon  
#3 Posted : Saturday, September 26, 2020 8:45:21 PM(UTC)
Pidgeon

Rank: Newbie

Reputation:

Groups: Approved
Joined: 9/25/2020(UTC)
Posts: 6
Italy

Thanks: 1 times
It is supposed to activate this tool:

https://github.com/daanzu/Switcheroo

If I associate the Ctrl+Alt+Space shortcut to the tool through its settings window, then it perfectly works when triggered "by hand".

But, when activating it through Strokesplus gesture, it is as Ctrl and Alt modifiers are kept pressed.

The only way to go back to normal in this case, is to manually press Ctrl and Alt at least once.
Pidgeon  
#4 Posted : Sunday, September 27, 2020 3:08:54 PM(UTC)
Pidgeon

Rank: Newbie

Reputation:

Groups: Approved
Joined: 9/25/2020(UTC)
Posts: 6
Italy

Thanks: 1 times
I wrote this AHK script to do some tests:

Code:
^!a::
SetTimer, checkModifiers, 100
Return

checkModifiers:
  Tooltip % modifiers()
  Return

modifiers()
{
  GetKeyState, varLWIN, LWIN
  GetKeyState, varLWINP, LWIN, P
  
  GetKeyState, varRWIN, RWIN
  GetKeyState, varRWINP, RWIN, P
  
  GetKeyState, varLSHIFT, LSHIFT
  GetKeyState, varLSHIFTP, LSHIFT, P
  
  GetKeyState, varRSHIFT, RSHIFT
  GetKeyState, varRSHIFTP, RSHIFT, P
  
  GetKeyState, varLALT, LALT
  GetKeyState, varLALTP, LALT, P
  
  GetKeyState, varRALT, RALT
  GetKeyState, varRALTP, RALT, P
  
  GetKeyState, varLCTRL, LCTRL
  GetKeyState, varLCTRLP, LCTRL, P
  
  GetKeyState, varRCTRL, RCTRL
  GetKeyState, varRCTRLP, RCTRL, P
  
  ; -----------------------------
  
  GetKeyState, varLBUTTON, LBUTTON
  GetKeyState, varLBUTTONP, LBUTTON, P
  
  GetKeyState, varMBUTTON, MBUTTON
  GetKeyState, varMBUTTONP, MBUTTON, P
  
  GetKeyState, varRBUTTON, RBUTTON
  GetKeyState, varRBUTTONP, RBUTTON, P
  
  Return % "Key	[L]	[P]`r`n"
         . "LWIN	[" . varLWIN . "]	[" . varLWINP . "]`r`n"
         . "RWIN	[" . varRWIN . "]	[" . varRWINP . "]`r`n"
         . "LSHIFT	[" . varLSHIFT . "]	[" . varLSHIFTP . "]`r`n"
         . "RSHIFT	[" . varRSHIFT . "]	[" . varRSHIFTP . "]`r`n"
         . "LALT	[" . varLALT . "]	[" . varLALTP . "]`r`n"
         . "RALT	[" . varRALT . "]	[" . varRALTP . "]`r`n"
         . "LCTRL	[" . varLCTRL . "]	[" . varLCTRLP . "]`r`n"
         . "RCTRL	[" . varRCTRL . "]	[" . varRCTRLP . "]`r`n"
         ; -----------------------------
         . "LBUTTON	[" . varLBUTTON . "]	[" . varLBUTTONP . "]`r`n"
         . "MBUTTON	[" . varMBUTTON . "]	[" . varMBUTTONP . "]`r`n"
         . "RBUTTON	[" . varRBUTTON . "]	[" . varRBUTTONP . "]"
}


I can confirm that when triggering the action I mentioned above (Ctrl + Alt + Space), then the script reports that Alt and Ctrl modifiers are pressed. I have to manually press them to put them back into the "Unpressed" state.

Unfortunately this is a serious bug which actually doesn't allow me to use the tool. I tried to run it on a different Windows 10 PC, and this problem didn't occur, strangely. I have no problem running further tests.
Rob  
#5 Posted : Monday, September 28, 2020 6:31:44 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 718
United States
Location: Tampa, FL

Thanks: 14 times
Was thanked: 163 time(s) in 141 post(s)
Quote:
I tried to run it on a different Windows 10 PC, and this problem didn't occur, strangely.


I also cannot reproduce it, which logic would dictate means it is likely a local issue to the PC you're having the problem on.

I would work to eliminate hardware and software as culprits. Meaning, start by reviewing and closing every non-critical application and running services to determine if another application is interfering.

Next backup your StrokesPlus.net.bin file (by default installed in C:\Users\{USERNAME}\AppData\Roaming\StrokesPlus.net\, then uninstall S+ and reinstall S+ using the default configuration. Simply close S+ and overwrite the StrokesPlus.net.bin file to restore your configuration.

Next, eliminate any potential hardware issues. Is there a KVM in play? Have you tried a different keyboard?

The code which handles this is fairly simple and doesn't have any kind of conditional logic in the sending of up and down logic, so it's either hardware/software interference, or possibly something within your configuration which is causing the issue.

If you take your StrokesPlus.net.bin file and put it on the other computer (which is not having the issue), does the issue start happening there?
Pidgeon  
#6 Posted : Friday, October 9, 2020 2:50:46 PM(UTC)
Pidgeon

Rank: Newbie

Reputation:

Groups: Approved
Joined: 9/25/2020(UTC)
Posts: 6
Italy

Thanks: 1 times
I finally solved the problem by running StrokesPlus.Net (portable) as Administrator.

Thanks for the help!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.