StrokesPlus.net
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
F9y4ng  
#1 Posted : Thursday, June 27, 2019 8:51:05 AM(UTC)
F9y4ng

Rank: Newbie

Reputation:

Groups: Approved
Joined: 6/20/2019(UTC)
Posts: 8
China

Since upgrading to 0.3.1.7 and 0.3.1.8, strokesplus. net has been stopped working Frequently. What happened to it?

UserPostedImage
UserPostedImage
UserPostedImage
UserPostedImage
UserPostedImage
Rob  
#2 Posted : Thursday, June 27, 2019 10:08:38 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 208
United States

Thanks: 4 times
Was thanked: 39 time(s) in 32 post(s)
Very little was changed, and the only thing I can think of that would cause an argument out of range would relate to the text expansion changes.

Are you using text expansions?
Can you find any consistency to the crash? Does it always seem to crash after you've done something specific?
F9y4ng  
#3 Posted : Friday, June 28, 2019 5:22:56 AM(UTC)
F9y4ng

Rank: Newbie

Reputation:

Groups: Approved
Joined: 6/20/2019(UTC)
Posts: 8
China

Originally Posted by: Rob Go to Quoted Post

Are you using text expansions?

No

Originally Posted by: Rob Go to Quoted Post

Can you find any consistency to the crash? Does it always seem to crash after you've done something specific?

I didn't do anything special. The strokeplus. NET program crashes resulted in severe system failure, and You can also see an unexpected shutdown.
If there's any consistency, it's that the mouse gesture gets stuck unexpectedly and gets strokeplus. NET will report a script error. After several retries, the system will start blocking and will not respond in severe cases.
I don't know what happened, but these occurred after the update of 0.3.1.7 and 0.3.1.8.

Rob  
#4 Posted : Friday, June 28, 2019 8:55:59 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 208
United States

Thanks: 4 times
Was thanked: 39 time(s) in 32 post(s)
I've compared the source code between 0.3.1.6 and 0.3.1.7 & 0.3.1.8, and I cannot find any change that would suddenly introduce a crash, at least not that I can find.

The ArgumentOutOfRange and ArgmentNullException are puzzling, well without context.

You say that you see a script error, Is there a particular script which is executing when this happens?

Can you post the script, or any details of what the script error reports?

Are there particular types of actions you're performing when this occurs? Like, a click script, rocker gesture pair?

Really, I'm having trouble locating where this would occur and I need some more specifics to narrow it down, since I've not had any issues since the updates.
Can you perform a full export and send me the file?
F9y4ng  
#5 Posted : Saturday, June 29, 2019 1:56:31 AM(UTC)
F9y4ng

Rank: Newbie

Reputation:

Groups: Approved
Joined: 6/20/2019(UTC)
Posts: 8
China

Originally Posted by: Rob Go to Quoted Post
I've compared the source code between 0.3.1.6 and 0.3.1.7 & 0.3.1.8, and I cannot find any change that would suddenly introduce a crash, at least not that I can find.

The ArgumentOutOfRange and ArgmentNullException are puzzling, well without context.

You say that you see a script error, Is there a particular script which is executing when this happens?

Can you post the script, or any details of what the script error reports?

Are there particular types of actions you're performing when this occurs? Like, a click script, rocker gesture pair?

Really, I'm having trouble locating where this would occur and I need some more specifics to narrow it down, since I've not had any issues since the updates.
Can you perform a full export and send me the file?


Another program crash just happened today.
Before that, I didn't use any mouse gestures. S+. NET itself crashed in the background.
The following is the error message:

UserPostedImage
UserPostedImage
Rob  
#6 Posted : Saturday, June 29, 2019 2:19:27 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 208
United States

Thanks: 4 times
Was thanked: 39 time(s) in 32 post(s)
Can you get the full error from the Event Viewer?

Usually there are two errors, one which looks like what you see below, and one that sometimes provide extra details which indicate the location of the crash.
F9y4ng  
#7 Posted : Saturday, June 29, 2019 3:24:58 AM(UTC)
F9y4ng

Rank: Newbie

Reputation:

Groups: Approved
Joined: 6/20/2019(UTC)
Posts: 8
China

Originally Posted by: Rob Go to Quoted Post
Can you get the full error from the Event Viewer?

Usually there are two errors, one which looks like what you see below, and one that sometimes provide extra details which indicate the location of the crash.

Code:

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <Level>2</Level> 
  <Task>100</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2019-06-29T07:46:49.629289900Z" /> 
  <EventRecordID>23114</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>F9Y4NG</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>StrokesPlus.net.exe</Data> 
  <Data>0.3.1.8</Data> 
  <Data>5d1374bf</Data> 
  <Data>KERNELBASE.dll</Data> 
  <Data>10.0.17763.592</Data> 
  <Data>aee8f822</Data> 
  <Data>e0434352</Data> 
  <Data>0000000000039129</Data> 
  <Data>1bb4</Data> 
  <Data>01d52e367f52a047</Data> 
  <Data>D:\Program Files\StrokesPlus.net\StrokesPlus.net.exe</Data> 
  <Data>C:\WINDOWS\System32\KERNELBASE.dll</Data> 
  <Data>c631afb3-e5ac-4310-8b67-2e0d67447db0</Data> 
  <Data /> 
  <Data /> 
  </EventData>
  </Event>



Code:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name=".NET Runtime" /> 
  <EventID Qualifiers="0">1026</EventID> 
  <Level>2</Level> 
  <Task>0</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2019-06-29T07:46:49.059095100Z" /> 
  <EventRecordID>23113</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>F9Y4NG</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>应用程序: StrokesPlus.net.exe Framework 版本: v4.0.30319 说明: 由于未经处理的异常,进程终止。异常信息: System.ArgumentNullException 在 System.Threading.Monitor.Enter(System.Object) 在 StrokesPlus.net.Hooks.HookState.cancelTimerCallback(System.Object) 在 System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) 在 System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) 在 System.Threading.TimerQueueTimer.CallCallback() 在 System.Threading.TimerQueueTimer.Fire() 在 System.Threading.TimerQueue.FireNextTimers()</Data> 
  </EventData>
  </Event>

Edited by user Saturday, June 29, 2019 12:44:40 PM(UTC)  | Reason: Not specified

Rob  
#8 Posted : Saturday, June 29, 2019 4:26:05 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 208
United States

Thanks: 4 times
Was thanked: 39 time(s) in 32 post(s)
There we go, cancelTimerCallback.

Okay, I'll take a look into that, though I definitely didn't change anything in that area.
Rob  
#9 Posted : Saturday, June 29, 2019 4:37:34 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 208
United States

Thanks: 4 times
Was thanked: 39 time(s) in 32 post(s)
Weird, I was not referencing the intended object for locking, but I don't understand why this is the first time it has been brought up.

Try the latest version, 0.3.1.9, and let me know if you are still having crashes.
F9y4ng  
#10 Posted : Saturday, June 29, 2019 12:46:27 PM(UTC)
F9y4ng

Rank: Newbie

Reputation:

Groups: Approved
Joined: 6/20/2019(UTC)
Posts: 8
China

Originally Posted by: Rob Go to Quoted Post
Weird, I was not referencing the intended object for locking, but I don't understand why this is the first time it has been brought up.

Try the latest version, 0.3.1.9, and let me know if you are still having crashes.


OK.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.