StrokesPlus.net
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
zyxi  
#1 Posted : Friday, May 10, 2019 5:37:28 AM(UTC)
zyxi

Rank: Advanced Member

Reputation:

Groups: Approved
Joined: 3/30/2019(UTC)
Posts: 49
China

Thanks: 4 times
Was thanked: 1 time(s) in 1 post(s)
Hi, Rob.

This is a bug. When the type is set to 6 rows and 6 columns, the saved software automatically returns to 1 row and 1 column, whether global or software customization.

Thank you for your selfless dedication again.
Rob  
#2 Posted : Friday, May 10, 2019 6:14:58 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 261
United States

Thanks: 5 times
Was thanked: 53 time(s) in 45 post(s)
Can you please provide more details?

I need to have some specifics, what each setting is, how things are configured, the steps to reproduce, the expected result and the actual result.
zyxi  
#3 Posted : Friday, May 10, 2019 7:24:10 AM(UTC)
zyxi

Rank: Advanced Member

Reputation:

Groups: Approved
Joined: 3/30/2019(UTC)
Posts: 49
China

Thanks: 4 times
Was thanked: 1 time(s) in 1 post(s)
I am sorry that I did not make it clear. You can try setting the split type to 6x6 in the Global gesture.
A few minutes later, you can see whether the strokesplus.net automatically changes the split type to 1x1 .
This situation has appeared several times on my computer, I don't know why.
Rob  
#4 Posted : Friday, May 17, 2019 11:47:04 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 261
United States

Thanks: 5 times
Was thanked: 53 time(s) in 45 post(s)
I have not forgotten about this :)

It's just going to take a little time until I get back to it.
zyxi  
#5 Posted : Tuesday, May 21, 2019 3:48:24 AM(UTC)
zyxi

Rank: Advanced Member

Reputation:

Groups: Approved
Joined: 3/30/2019(UTC)
Posts: 49
China

Thanks: 4 times
Was thanked: 1 time(s) in 1 post(s)
Thank you for your reply. There is still a problem in the process of using it.
Sometimes you click on the left mouse button, but it performs the function of the right mouse button.
What could cause this problem? The same problem has been bothering me in the strokesplus.
Rob  
#6 Posted : Thursday, May 23, 2019 6:38:12 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 261
United States

Thanks: 5 times
Was thanked: 53 time(s) in 45 post(s)
When you say click the left button and it performs the right button action, I've not heard of that before. Can you give me some specific examples, and how you have your setup configured?

I'm travelling this week, so I haven't had the chance to look at the columns and rows issue yet.
zyxi  
#7 Posted : Monday, May 27, 2019 5:43:05 AM(UTC)
zyxi

Rank: Advanced Member

Reputation:

Groups: Approved
Joined: 3/30/2019(UTC)
Posts: 49
China

Thanks: 4 times
Was thanked: 1 time(s) in 1 post(s)
Dear Rob,
thank you for your long-term attention. Now I have found an example to illustrate this problem.
You can execute the script between two folders (that is, after executing on one folder,
then using the script on another folder) and loop the operation several times,
then right-click on one of the folders. This bug may occur at this time.


[img=https://imgchr.com/i/VZhQIO]https://imgchr.com/i/VZhQIO[/img]


code:

sp.MouseClick(action.Start, MouseButtons.Left, true, true);
//Click the Left mouse butto
sp.Sleep(10)
sp.SendKeys("{DELETE}")
sp.Sleep(100)
sp.SendKeys("y")
sp.MouseMove(action.End);

Note: You need to choose the Alt modifier key to execute this script.

Thank you for your reply again.
zyxi  
#8 Posted : Monday, May 27, 2019 5:45:34 AM(UTC)
zyxi

Rank: Advanced Member

Reputation:

Groups: Approved
Joined: 3/30/2019(UTC)
Posts: 49
China

Thanks: 4 times
Was thanked: 1 time(s) in 1 post(s)
UserPostedImage
Rob  
#9 Posted : Monday, May 27, 2019 6:28:39 AM(UTC)
Rob

Rank: Administration

Reputation:

Groups: Translators, Members, Administrators
Joined: 1/11/2018(UTC)
Posts: 261
United States

Thanks: 5 times
Was thanked: 53 time(s) in 45 post(s)
I think I have found the problem with the rows and columns, so let me know if you still encounter the issue after version 0.3.0.4.

Regarding your click issue, I am having difficulty reproducing the problem. It looks like this is simply deleting a file/folder, right?

One thing I can suggest is to prevent physical mouse and keyboard input during your script's execution, to avoid any interference from your keyboard and mouse activity while the script is also simulating mouse and keyboard events.

Code:
sp.ConsumePhysicalInput(true);
sp.MouseClick(action.Start, MouseButtons.Left, true, true);
//Click the Left mouse butto
sp.Sleep(10)
sp.SendKeys("{DELETE}") 
sp.Sleep(100)
sp.SendKeys("y")
sp.MouseMove(action.End);
sp.ConsumePhysicalInput(false);


Also, the sp.SendKeys("y") wasn't adding anything for me since delete was deleting the file, "y" was just trying to select the first file beginning with the letter "y" after the delete was performed. But that would probably behave differently depending on the folder, if a confirmation prompt would normally appear for where you're using it.

You say "and loop the operation several times, then right-click on one of the folders"...what happens when you right click one of the folder? Since I cannot create the issue, I might need a very detailed account of each thing that is happening.

For example:
- I hold the Alt key and perform the action, the folder is deleted
- I repeat the action over a different folder while I am still holding the Alt key (or I released the Alt key and pressed it again), the folder is deleted
- I repeat this process 3 times and it functions as expected
- Then I simply right click on a different folder, and {something} happens

zyxi  
#10 Posted : Monday, May 27, 2019 7:35:15 AM(UTC)
zyxi

Rank: Advanced Member

Reputation:

Groups: Approved
Joined: 3/30/2019(UTC)
Posts: 49
China

Thanks: 4 times
Was thanked: 1 time(s) in 1 post(s)

I need time to check if there is a problem with the rows and columns in the new version´╝î
and if it still exists, I will continue to submit bugs.

The second problem sometimes appears in my computer. It may be my computer problem,
or it may take longer to find out what's wrong with it. If I find a better example,
I will continue to discuss this with you.

Thank you for your help.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.